Конфедерации – правила маршрутизации в сети Internet

На схеме, представленной на рис. 12.14, показано, как разделить AS3 на две меньших подсистемы — AS65050 и AS65060. Номера подсистем AS выбраны из диапазона частных номеров (64512—65535). В каждой из подсистем AS в качестве протокола IGP используется протокол OSPF. Причем OSPF внутри AS65050 не зависит от OSPF в AS65060, т.е. номера областей, используемые в AS65050, можно повторно использовать в AS65060. Таким образом, вы получаете определенное преимущество по сравнению даже с BGP, если IGP в одной подсистеме AS не зависит от 1GP в другой подсистеме AS.

Рис. 12.14. Конфедерации

Из конфигурации маршрутизатора RTA, приведенной в листинге 12.73, видно, что все его интерфейсы находятся в области OSPF с номером 5. На маршрутизаторе RTA для взаимодействия с RTC в AS1 поддерживается протокол EBGP, а для работы с RTG в AS65050 – протокол IBGP.

Обратите внимание, что на маршрутизаторе RTA субкоманда bgp configuration identifier 3 помогает представить его маршрутизатору RTC как члена конфедерации 3.

Листинг 12.73. Конфедерации (конфигурация маршрутизатора RTA)

router ospf 10

passive-interface Serial

network 172.16.0.0 0.0.255.255 area 5

router bgp 65050

no synchronization

bgp confederation identifier 3

network 172.16.220.0 mask 255.255.255.0

network 172.16.70.0 mask 255.255.255.0

neighbor 172.16.20.1 remote-as 1

neighbor 172.16.20.1 filter-list 10 out

neighbor 172.16.70.2 remote-as 65050

no auto-summary

ip as-path access-list 10 permit A$

Как видно из листинга 12.74, на маршрутизаторе RTC при взаимодействии с RTA используется обычный протокол EBGP. С точки зрения RTC, маршрутизатор RTA принадлежит AS3. Он также не имеет сведений о подсистемах AS внутри конфедерации 3. И с маршрутизатором RTH в AS2 RTC также взаимодействует по EBGP.

Листинг 12.74. Конфедерации (конфигурация маршрутизатора RTC)

router bgp  1

network   192.68.11.0

neighbor   172.16.20.2   remote-as   3

neighbor   192.68.6.1  remote-as 2

  no auto-summary                                                              

Маршрутизатор RTG является граничным для подсистемы AS65050 и взаимодействует с RTF в подсистеме AS65060 по EBGP для конфедераций (confederation EBGP). Кроме того, с маршрутизатором RTA он взаимодействует с помощью протокола IBGP. К тому же RTG является граничным маршрутизатором, который имеет общую с RTA область OSPF 5, а остальные его интерфейсы лежат в области 0. Обратите внимание, что в RTG запрещена обработка данных, поступающих по протоколу OSPF через интерфейс Serial I (passive-interface Serial 1), который к тому же является общим с маршрутизатором RTF. В этом соединении поддерживается только протокол EBGP. В листинге 12.75 приведена конфигурация маршрутизатора RTG.

Листинг 12.75. Конфедерации (конфигурация маршрутизатора RTG)

router  ospf 10

passive-interface Seriall

network 172.16.70.2   0.0.0.0 area 5

network 172.16.0.0  0.0.255.255  area   0

router bgp  65050 no synchronization

bgp  confederation identifier 3

bgp  confederation peers   65060

network  172.16.112.0 mask 255.255.255.0

network  172.16.50.0 mask 255.255.255.0

network 172.16.70.0 mask 255.255.255.0

neighbor 172.16.50.1  remote-as  65060

neighbor 172.16.50.1 next-hop-self

neighbor   172.16.70.1   remote-as   65050

  no auto-summary                                                              

Как видите, RTG также идентифицирует себя как часть конфедерации 3 (bgp confederation identifier 3). Чтобы сохранить все атрибуты, такие как LOCAL_PREF и NEXT_HOP, при проведении EBGP-сеанса с AS65060 на RTG используется команда bgp confederation peers 65060. С помощью этой команды EBGP-сеанс для конфедерации с подсистемой AS65060 будет выглядеть как сеанс по протоколу IBGP. С помощью команды

neighbor 172.16.50.1 next-hop-self для маршрутов, поступающих от RTG на RTF, в качестве адреса следующего ближайшего узла будет устанавливаться IP-адрес марш руги затора RTG. Без этой команды адрес следующего ближайшего узла для всех EBGP-маршрутов от AS1 будет посылаться на RTF равным 172.16.20.1, что действительно только при наличии к нему доступа из конфедерации маршрутизаторов в подсистеме AS65060.

Как видно из листинга 12.76, та же конфигурация применяется и на маршрутизаторе RTF, который также является граничным для подсистемы AS65060. Кроме того, RTF является граничным маршрутизатором для областей 0 и 5. Области 0 и 5 в AS65060 абсолютно не зависят от таких же областей в AS65050. Таким образом, оба протокола IGP "защищены" друг от друга посредством BGP. При этом между маршрутизаторами RTE, RTD и RTF поддерживается полносвязная схема взаимодействия с использованием протокола IBGP и группы узлов с именем SUB_AS_65060.

Листинг 12.76. Конфедерации (конфигурация маршрутизатора RTF)

router ospf 10

passive-interface Serial2/l

network 172.16.25.1   0.0.0.0 area 5

network 172.16.0.0  0.0.255.255 area 0

router bgp  65060 no synchronization

bgp  confederation identifier 3

bgp  confederation peers   65050

network 172.16.65.0 mask  255.255.255.192

network 172.16.50.0 mask 255.255.255.0

network 172.16.25.0 mask 255.255.255.0

network 172.16.30.0 mask 255.255.255.0

neighbor SUB_AS_65060 peer-group neighbor SUB_AS_65060 remote-as  65060

neighbor 172.16.25.2 peer-group  SUB_AS_65060

neighbor 172.16.30.2 peer-group SUB_AS_65060 neighbor 172.16.50.2  remote-as  65050

  neighbor 172.16.50.2 nexthopself                                          

Маршрутизатор RTD является граничным для конфедерации 3. Как видно из листинга 12.77, RTD взаимодействует с RTH в AS2 по протоколу EBGP и по полносвязной схеме — с RTE и RTF в подсистеме AS65060. Все интерфейсы маршрутизатора RTD находятся в области 0. На RTD не поддерживается OSPF во внешнем канале с AS2. Вот почему для внешних обновлений, поступающих на RTD, в качестве следующего ближайшего узла следует задать его же, прежде чем распространять эти сведения в направлении RTF и RTE.

Листинг 12.77. Конфедерации (конфигурация маршрутизатора RTD)

router  ospf 10

network 172.16.0.0  0.0.255.255 area 0.0.0.0

router bgp  65060 no synchronization

bgp  confederation identifier 3 network 172.16.90.0 mask 255.255.255.0

network 172.16.30.0 mask 255.255.255.0

neighbor 172.16.25.2  remote-as  65060

neighbor   172.16.25.2 next-hop-self

neighbor   172.16.30.1   remote-as   65060

neighbor 172.16.30.1  next-hop-self

neighbor 192.68.20.2  remote-as  2

neighbor 172.16.20.2  filter-list 10 out no auto-summary

ip  as-path access-list  10 permit  A$

Как видно из листинга 12.78, все интерфейсы маршрутизатора RTE лежат в области 5 протокола OSPF, и он поддерживает полносвязную схему IBGP с RTF и RTD.

Листинг 12.78. Конфедерации (конфигурация маршрутизатора RTE)

router  ospf 10

network 172.16.0.0  0.0.255.255 area 5

router bgp  65060  no synchronization

bgp  confederation identifier 3 network 172.16.60.0 mask 255.255.255.0

network 172.16.25.0 mask 255.255.255.0

neighbor 172.16.25.1 remote-as   65060

neighbor 172.16.30.2  remote-as  65060

  no auto-summary                                                              

Как показано в листинге 12.79, маршрутизатор RTH является граничным для AS2 и на нем поддерживается протокол EBGP для обеспечения взаимодействия между AS1 и AS3. При этом RTH не имеет сведений о подсистемах AS в конфедерации 3.

Листинг 12.79. Конфедерации (конфигурация маршрутизатора RTH)

router bgp 2

network 192.68.222.0

neighbor 192.68.6.2   remote-as   1

neighbor   192.68.20.1   remote-as   3

  no auto-summary                                                              

Теперь давайте рассмотрим несколько фрагментов таблиц BGP-маршрутов. Посмотрите, как на маршрутизаторе RTH отображаются маршруты (листинг 12.80). Это делается через AS1 и через AS3. Как видите, все подсистемы AS "невидимы" для RTH.

Листинг 12.80. Конфедерации (таблица BGP-маршрутов на маршрутизаторе

RTH)

RTC# show ip bgp

BGP table version is 477, local router ID is 192.68.222.1

Status codes: s suppressed, d damped, h history, * valid, > best,

Рассмотрим  теперь  таблицу  BGP-маршрутов  на  маршрутизаторе  RTA,  которая представлена в листинге 12.81. Из нее видно, что все подсистемы AS заключены в скобки.

Любой маршрут между подсистемами AS имеет длину 0. Посмотрим, как двумя способами получаются сведения о префиксе 192.68.222.0/24: через внутренний маршрут (65060) 2 и через внешний маршрут 1 2. Длина внутреннего маршрута (65060) 2 считается меньшей, так как подсистемы AS при вычислении длины маршрута не учитываются. Именно поэтому был выбран внутренний маршрут.

Листинг 12.81. Конфедерации (таблица BGP-маршрутов на маршрутизаторе

RTA)

RTC# show ip bgp

BGP table version is 13, local router ID is 172.16.220.1

Status codes: s suppressed, d damped, h history, * valid, > best,

В таблице BGP на маршрутизаторе  RTF, представленной в листинге 12.82, все маршруты от подсистемы AS65050 считаются внешними маршрутами конфедерации (внешние конфедераты). Внутри конфедерации решение принимается на основе следующих положений: маршруты EBGP более предпочтительны, чем внешние конфедераты, которые, в свою очередь, более предпочтительны, чем внутренние маршруты.

Листинг 12.82. Конфедерации (BGP-таблица на маршрутизаторе RTA)

RTF#show ip bgp 172.16.220.0

BGP routing table entry for 172.16.220.0/24, version 22 Paths: (1 available, best #1, advertised over IBGP)

(65050)

from 172.16.50.2 (172.16.112.1)

 Origin IGP, metric 0, localpref 100, valid, confed-external, best              

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100