Статические маршруты по умолчанию – правила маршрутизации в сети Internet

Рис. 12.2. Обработка маршрута по умолчанию 0/0

Вместо того чтобы получать сведения о маршруте по умолчанию 0/0 динамически, маршрутизатор может установить собственный статический маршрут по умолчанию. На рис.

12.2 показано, как это делается.

Вы можете на маршрутизаторе RTC использовать следующую команду:

ip route prefix mask {address \ interface} [distance]

Статический маршрут по  умолчанию 0/0 при этом может указывать на сетевой адрес, адрес шлюза или физический интерфейс. Здесь параметр distance является средством, с помощью которого вы можете задать статическому маршруту определенный уровень предпочтения, если существует несколько точек входа в сеть. Маршруты с меньшей дистанцией (значением distance) предпочитаются маршрутам с более длинной дистанцией.

В листинге  12.4  показано, как  на маршрутизаторе RTC  установить маршрут  по

умолчанию в направлении сети 193.78.0.0/16.

Листинг 12.4. Конфигурирование маршрутизатора RTC для установки маршрута по умолчанию в сеть 193.78.0.0/16

router bgp  1

network 192.68.11.0

neighbor 172.16.20.2 remote-as 3

neighbor 192.68.6.1 remote-as 2

no auto-summary ip route 0.0.0.0  0.0.0.0  193.78.0.0

Из таблицы BGP-маршрутов на маршрутизаторе RTC, представленной в листинге

12.5                    , видно, что маршрут в сеть 193.78.0.0/16 был получен двумя путями — через AS3 и через AS2. В протоколе BGP, как мы знаем, предпочтение отдается наилучшему маршруту. (Чтобы повлиять на выбор маршрута, можно использовать атрибуты BGP).

Листинг 12.5. Таблица BGP-маршрутов на маршрутизаторе RTC

RTC# show ip bgp

BGP table version is 8, local router ID is 192.68.11.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal Origin codes: i – IGP, e – EGP, ? i          

Из таблицы IP-маршрутов на маршрутизаторе RTC, приведенной в листинге 12.6, видно, каким образом установлен шлюз по умолчанию, чтобы достичь сети 193.78.0.0./16. При рекурсивном просмотре таблицы IP-маршрутов видно, что в сеть 193.78.0.0/16 можно попасть через узел с адресом 172.16.20.2 (т.е. RTA).

Листинг 12.6. Таблица IP-маршрутов на маршрутизаторе RTC

RTC#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  – BGP

D            – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area El – OSPF external type 1, E2 – OSPF external type 2, E – EGP i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default u – per-user static route

Gateway of last resort is 193.78.0.0 to network 0.0.0.0 192.68.6.0/24 is directly connected, EthernetO/1 192.68.11.0/24 is directly connected, EthernetO/0 193.78.0.0/16 [20/0] via 172.16.20.2, 00:32:32

172.16.20.0/24 is directly connected, Serial2/l

 S* 0.0.0.0/0 [1/0] via 193.78.0.0                                              

Если вы не хотите, чтобы трафик следовал по одному маршруту, то можно воспользоваться командой ip route 0.0.0.0 0.0.0.0, чтобы направить его в несколько сетей сразу или по нескольким IP-адресам одновременно. Ключевое слово distance дает вам в этом случае возможность устанавливать для маршрутов уровни предпочтения, как это показано в листинге 12.7.

Листинг 12.7. Применение distance для предпочтения одного маршрута по умолчанию другому (конфигурация маршрутизатора RTC)

router bgp 1

network 192.68.11.0

neighbor 172.16.20.2  remote-as  3

neighbor 192.68.6.1 remote-as 2 no auto-summary

ip route  0.0.0.0   0.0.0.0 172.16.20.2  40

 ip route  0.0.0.0   0.0.0.0 192.68.6.1   50                                  

Обратите внимание, что на маршрутизаторе RTC указываются два различных IP- адреса. Это могут быть также два адреса сетей, которые присутствуют в маршрутной IP- таблице. Дистанция первого статического маршрута 40 говорит о том, что до тех пор, пока будет доступен узел 172.16.20.2, этот маршрут будет предпочитаться второму. Если же узел 172.16.20.2 выходит из строя, то запись о статическом маршруте к нему изымается и активным становится второй маршрут (см. таблицу маршрутов на маршрутизаторе RTC в листинге 12.8).

Листинг 12.8. Таблица маршрутов RTC

RTC#show ip route

Codes:  – connected, S – static, I – IGRP, R — RIP, M — mobile,  – BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area

El – OSPF external type 1, E2 – OSPF external type 2, E E           G                         P                           

В листинге 12.9 показаны результаты выполнения той же команды, если пропадает канал между RTA и RTC.

Листинг 12.9. Таблица маршрутов на маршрутизаторе RTC после пропадания канала RTC.RTA

RTC#show ip route

Codes:  – connected, S – static, I – IGRP, R — RIP, M — mobile,  – BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area

El – OSPF external type 1, E2 – OSPF external type 2, E

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100