Распределение    нагрузки    между    двумя    маршрутизаторами, которые совместно используют несколько каналов – правила маршрутизации в сети Internet

Этот раздел посвящен вопросам организации распределения нагрузки между двумя

маршрутизаторами,  которые  взаимодействуют  по  нескольким  каналам  без  дублирования идентичной маршрутной информации. Мы рассмотрим ситуацию с двумя каналами.

В схеме сети, предложенной на рис. 12.6, необходимо настроить на маршрутизаторах RTA и RTC петельные интерфейсы (листинги 12.22 и 12.23) и организовать между этими маршрутизаторами сеанс связи. С  помощью статических маршрутов вы сможете явно указать маршруты через физические интерфейсы к обоим петельным интерфейсам. Тогда таблица IP-маршрутов будет содержать два маршрута к ближайшему соседнему узлу, и появится возможность распределения нагрузки.

Рис. 12.6. Распределение нагрузки между двумя маршрутизаторами, которые совместно используют два канала связи

Листинг 12.22. Распределение нагрузки между двумя маршрутизаторами, которые совместно используют два канала связи (конфигурация маршрутизатора RTA)

interface LoopbackO

ip address 172.16.2.254 255.255.255.255

router bgp 3

no synchronization

  neighbor 172.16.90.1 remote-as 1                                              

neighbor 172.16.90.1 ebgp-multlhop 2 neighbor 172.16.90.1 update-source LoopbackO no auto-summary

ip route 172.16.90.1 255.255.255.255 172.16.20.1

 ip route 172.16.90.1 255.255.255.255 172.16.60.1                               

Листинг 12.23. Распредепение нагрузки между двумя маршрутизаторами, которые совместно используют два канала связи (конфигурация маршрутшатора RTC)

interface LoopbackO

ip address 172.16.90.1 255.255.255.255

router bgp 1 .

network 192.68.11.0

neighbor 172.16.2.254   remote-as   3

neighbor 172.16.2.254 ebgp-multihop 2 neighbor 172.16.2.254 update-source LoopbackO no auto-summary

ip route  172.16.2.254  255.255.255.255  172.16.20.2

 ip  route 172.16.2.254   255.255.255.255   172.16.60.2                        

В листинге 12.24 представлено, как теперь маршрутизатор RTA получает от RTC сведения о BGP-маршрутах. Это происходит через узел с адресом 172.16.90.1 (адрес петельного интерфейса). Обратите внимание, что адрес источника update-source сконфигурирован как параметр команды neighbor. Так устанавливается IP-адрес источника в TCP-соединении с заданным интерфейсом. Если он не определен, то для достижения взаимодействующего узла будет использоваться выходной интерфейс и узел разорвет соединение.

Листинг 12.24. Таблица BGP-маршрутов на маршрутизаторе RTA

RTC# show ip bgp

BGP table version is 4, local router ID is 172.16.2.254

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal Origin codes: i – IGP, e – EGP,

В таблице маршрутов на маршрутизаторе RTA два статических маршрута позволяют вести работу по двум каналам для обеспечения доступа на узел 172.16.90.1 (листинг 12.25). Так что маршрутизатор будет распределять нагрузку между двумя каналами.

Листинг 12.25. Таблица IP-маршрутов на маршрутизаторе RTA

RTAftshow ip route

Codes:  – connected, S – static, I – IGRP, R — RIP, M — mobile,  -BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

El – OSPF external type 1, E2 – OSPF external type 2,

Отметим, что все рассмотренные варианты распределения нагрузки действительны только для исходящего трафика. Подобным образом нужно настроить маршрутизатор и с другой стороны. Мы обсудим эти вопросы в последующих разделах.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100