Применение RIP в качестве протокола IGP – правила маршрутизации в сети Internet

Реализация протокола RIP в оборудовании Cisco существенно отличается от OSPF,

особенно при обработке маршрута по умолчанию вида 0/0. Маршрут по умолчанию 0/0, сведения о котором получены по BGP, автоматически переносится в RIP. Процесс RIP должен лишь назначить с помощью команды default-metric соответствующую метрику (число промежуточных узлов) маршруту по умолчанию. Предположим, что в нашем примере (см. рис. 12.11) на маршрутизаторах RTA, RTF и RTG поддерживается протокол RIP. Необходимо на маршрутизаторе RTA установить такую метрику для маршрута 0/0, который передается в RIP, чтобы внутренний маршрутизатор (RTG) всегда отдавал предпочтение маршрутизатору RTF.

С помощью конфигурации RTA, приведенной в листинге 12.47, маршруту по умолчанию 0/0 устанавливается метрика 5. Как видите, здесь не требуется преобразования маршрутов, чтобы передавать данные из BGP в RIP.

Листинг 12.47. Применение RIP в качестве протокола ЮР (конфигурация маршрутизатора RTA)

router  rip

passive-interface SerialO network 172.16.0.0

default-metric 5

router bgp  3

no synchronization

network 172.16.220.0 mask 255.255.255.0

network 172.16.70.0 mask 255.255.255.0

neighbor 172.16.20.1  remote-as  1

neighbor 172.16.20.1 filter-list 10 out

neighbor 172.16.50.1  remote-as  3

neighbor 172.16.50.1   route-map setlocalpref in

no auto-summary

ip as-path access-list 10  permit  A$ route-map setlocalpref permit 10

  set localpreference  300                                                   

С помощью конфигурации маршрутизатора RTF, представленной в листинге 12.48, объявляется RIP-маршрут 0/0 со счетчиком промежуточных узлов установленным в 1.

Листинг 12.48. Применение RIP в качестве протокола IGP (конфигурация маршрутизатора RTF)

router  rip

network 172.16.0.8 default-metric 1

router  bgp   3

no synchronization

network 172.16.50.0 mask 255.255.255.0

neighbor 192.68.5.2   filter-list 10 out no auto-summary

ip  as-path access-list  10 permit A$

Конфигурация маршрутизатора RTG, приведенная в листинге 12.49, позволяет работу на нем только по протоколу RIP, а весь трафик за пределы AS3 отправляется согласно маршруту по умолчанию 0/0.

Листинг 12.49. Применение RIP в качестве протокола IGP (конфигурация маршрутизатора RTG)

router rip

  network 172.16.0.0                                                            

В листинге 12.50 показано, как выглядит таблица IP-маршрутов на маршрутизаторе RTG. Как видите, на RTG установлен маршрут по умолчанию в направлении RTF, так как этот маршрут обладает более низкой метрикой 1.

Листинг 12.50. Таблица IP-маршрутов на маршрутизаторе RTG

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP

D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0 172.16.0.0/16 is subnetted, 4 subnets

R   172.16.220.0/24 [120/1] via 172.16.70.1, 00:00:03, SerialO

172.16.50.0/24 is directly connected, Seriall

R   172.16.20.0/24 [120/1] via 172.16.70.1, 00:00:03, SerialO

172.16.70.0/24 is directly connected, SerialO

 R* 0.0.0.0/0 [120/1] via 172.16.50.1, 00:00:22, Seriall                        

Примечание

Если  требуется  обеспечить  еще  несколько  условий,  согласно  которым  сведения  о маршруте   0/0   будут   пересылаться  в   RIP,   в   качестве   альтернативных   средств   можно

использовать преобразование из BGP в RIP и карты маршрутов.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100