Применение OSPF в качестве протокола IGP – правила маршрутизации в сети Internet

Маршрут по умолчанию вводится в OSPF с помощью следующей команды маршрутизатора:

default-information originate [always] [metric metric-value] [metric-type

type-value] [route-map map-name]

По команде default-information originate (без ключевого слова always) маршрут по умолчанию 0/0 преобразуется в OSPF-маршрут, но только в том случае, если маршрутизатор сам имеет маршрут по умолчанию. Здесь нельзя использовать ключевое слово always, так как при выходе из строя канала связи граничный маршрутизатор будет продолжать преобразование маршрута по умолчанию в IGP-маршрут, даже если он не сможет больше доставлять трафик по назначению. (Помните, что прямой связи между граничными маршрутизаторами нет!)

Если маршрутизаторы RTA и RTF сконфигурированы с командой default- information originate, то произойдет следующее,

Шаг 1. Маршрутизатор RTA получает сведения о маршруте по умолчанию по EBGP и по IBGP.

Шаг 2. Так как на RTA задано, что все должно проводиться через RTF (маршрут с более высоким локальным предпочтением), то он отдает предпочтение маршруту 0/0 по IBGP.

Шаг 3. Так как у RTA есть маршрут по умолчанию (по BGP), то он начинает преобразование его в IGP.

Итак, вы оказались в ситуации, когда оба маршрутизатора генерируют маршруты по умолчанию и вполне вероятно образование петли.

Вы можете сказать, что, поскольку канал NY является основным, то RTA не должен посылать сведения о маршрутах по умолчанию. Но подумайте, что произойдет, если выйдет из строя канал NY. При этом маршрутизатор RTF перестает объявлять маршрут по умолчанию 0/0 в IGP. И маршрутизатор RTA также не посылает никаких сведений о маршрутах по умолчанию, так что трафик не сможет покинуть пределы AS.

Решение этих проблем заключается в том, чтобы RTA и RTF объявляли маршрут по

умолчанию, только если у них  имеется этот маршрут и только в том случае, если он получил сведения о нем по EBGP. Когда маршрутизатор RTA обнаруживает, что маршрут по умолчанию 0/0 получен по EBGP, а не по IBGP, он сообщает, что с каналом NY что-то случилось и начинает самостоятельно посылать маршрут по умолчанию. Это можно сделать с помощью карты маршрутов совместно с командой default-information originate, как показано в листинге 12.42.

Листинг 12.42. Использование маршрута по умблчанию только в определенных

I обстоятельствах (конфигурация маршрутизатора RTA)

router  ospf 10

passive-interface  Serial0

network 172.16.0.0 0.0.255.255 area 0

default-information  originate route-map  SEND_DEFAULT_IF

router bgp  3

no synchronization

network 172.16.220.0 mask 255.255.255.0

  network  172.16.70.0 mask 255.255.255.0                                    

neighbor

172.16.20.1

remote-as   1

neighbor

172.16.20.1

filter-list 10 out

neighbor

172.16.50.1

remote-as   3

neighbor

172.16.50.1

route-map  setlocalpref in

no auto-summary

ip as-path access-list 10  permit  A$

access-list

1

permit

0.0.0.0

access-list

2

permit

172.16.20.1

route-map setlocalpref permit 10 set  local-preference 300

route-map SEND_DEFAULT_IF permit 10 match  ip address   1

  match ip next-hop 2                                                         

Обратите внимание, на карту маршрутов SEND_DEFAULT_IF, которая описывается в команде маршрутизатора default-information originate. Эта карта маршрутов выполняет проверку на соответствие условию, когда у маршрута по умолчанию 0/0 (access-list 1) в качестве следующего узла используется хост с адресом 172.16.20.1 (access-list 2). Это соответствует тому, что сведения о маршруте 0/0 получены по EBGP, а не по IBGP. Маршрутизатор RTA определяет, что канал NY вышел из строя и начинает передавать в OSPF собственный маршрут по умолчанию 0/0.

Вторая карта маршрутов setlocalpref присваивает значение локального предпочтения 300 всем IBGP-маршрутам на маршрутизаторе RTA. Таким образом, всем IBGP-маршрутам будет отдаваться предпочтение по сравнению с EBGP-маршрутами.

Как видно из листинга 12.43, на маршрутизаторе RTF также генерируется маршрут по умолчанию и посылается в OSPF только при условии, что сведения о нем получены по внешнему каналу (NEXT_HOP 192.68.5.2). В случае выхода из строя канала NY маршрутизатор RTF прекращает объявление маршрута 0/0, даже если он может получать его по IBGP от RTA.

Листинг 12.43. Прекращение объявления маршрута по умолчанию при определенных условиях (конфигурация маршрутизатора RTF)

router ospf 10

network 172.16.0.0  0.0.255.255 area 0

default-information originate route-map SEND_DEFAULT_IF

router bgp  3

no synchronization

network 172.16.50.0 mask 255.255.255.0

neighbor   172.16.70.1   remote-as   3

neighbor 172.16.70.1 next-hop-self

neighbor 192.68,5.2   remote-as 2

neighbor 192.68.5.2 filter-list 10 out

no auto-summary

ip as-path access-list 10 permit  A$ access-list 1  permit 0.0.0.0

access-list 2 permit 192.68.5.2

route-map SEND_DEFAULT_IF permit 10 match  ip address   1

  match ip nexthop 2                                                          

Как видно из листинга 12.44, на маршрутизаторе RTG поддерживается только протокол OSPF и установлен маршрут по умолчанию 0/0 для всех пунктов назначения за пределами AS.

Листинг 12.44. Установка маршрутов по умолчанию для пунктов назначения за пределами AS (конфигурация маршрутизатора RTG)

router  ospf 10

  network 172.16.0.0 0.0.255.255 area 0                                     

В листинге 12.45 представлена таблица IP-маршрутов на маршрутизаторе RTA. Как видите, здесь предпочтение отдается маршруту по умолчанию 0/0 через маршрутизатор RTF (взаимодействующий по  IBGP узел) с NEXT_HOP 172.16.50.1. Так как NEXT_HOP отличается от адреса внешнего взаимодействующего узла— 172.16.20.1, то RTA не будет передавать сведения о маршруте по умолчанию в OSPF.

Листинг 12.45. Таблица IP-маршрутов на маршрутизаторе RTA

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP

D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR

Gateway of last resort is 172.16.58.1 to network 0.0.0.0

           via    172.16.50.1,    00:03:06

193.78.0.0/16  [200/0]  via  172.16.50.1,   00:03:06

172.16.0.0/16 subnetted,  4  subnets

172.16.20.0/24   is directly connected,   SerialO 172.16.220.0/24  is directly connected,   Ethernetl

O    172.16.50.0/24   [110/164]  via  172.16.70.2,   02:17:37,   Seriall

172.16.70.0/24   is directly connected,   Seriall B* 0.0.0.0/0  [200/0]  via  172.16.50.1,   00:03:07

В листинге 12.46 представлена таблица IP-маршрутов на маршрутизаторе RTG. Посмотрите внимательно, как на RTG устанавливается маршрут по умолчанию в направлении RTF. Теперь все правила BGP-маршрутизации и маршруты по умолчанию в IGP синхронизированы (т.е. не конфликтуют).

Листинг 12.46. Таблица IP-маршрутов на маршрутизаторе RTG

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP  i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR Gateway of last resort   is  172.16.50.1 to network 0.0.0.0

172.16.50.0/24 is directly connected, Serial1 172.16.70.0/24 is directly connected, SerialO

 O*E2 0.0.0.0/0 [110/13 via 172.16.50.1, 00:41:26, Seriall                      

В случае выхода из строя канала NY маршрутизатор RTA будет получать сведения о маршруте 0/0 через внешний канал с промежуточным узлом 172.16.20.1 и посылать  их дальше в OSPF.

Преобразование BGP-маршрута 0/0 в OSPF-маршрут с помощью команды redistribute

в этом случае делать не следует.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100