Применение EIGRP в качестве протокола IGP – правила маршрутизации в сети Internet

Маршруты по умолчанию, сведения о которых распространяются с помощью BGP, поступают в EIGRP посредством преобразования. Метрики маршрута 0/0 при этом необходимо преобразовать в EIGRP-совместимые метрики с помощью субкоманды default- me trie.

Конфигурация маршрутизатора RTA, представленная в листинге 12.51, позволяет проводить подстановку маршрута по умолчанию с более высокой метрикой таким образом, что внутренний маршрутизатор (RTG) всегда будет получать маршрут в направлении RTF с меньшей метрикой.

Листинг 12.51. Применение EIGRP в качестве протокола IGP (конфигурация маршрутизатора RTА)

router eigrp 1

redistribute bgp 3 route-map DEFAULT_ONLY passive-interface SerialO

network 172.16.0.0

default-metric 5 100 250 100 1500

router bgp 3

no synchronization

network 172.16.70.0 mask 255.255.255.0

network 172.16.220.0 mask 255.255.255.0

neighbor 172.16.20.1 remote-as 1

neighbor 172.16.20.1 filter-list 10 out

neighbor 172.16.50.1 remote-as 3

neighbor 172.16.50.1 route-map setlocalpref in no auto-summary

ip as-path access-list 10 permit  A$ access-list 5 permit 0.0.0.0

route-map setlocalpref permit 10 set  local-preference 300

route-map DEFAULT_ONLY permit 10

  match ip address  5                                                         

На маршрутизаторе RTA используется карта маршрутов DEFAULT_ONLY, с помощью которой и выделяется маршрут по умолчанию 0/0. Все остальные обновления маршрутов не будут преобразованы в EIGRP. Кроме того, на RTA с помощью субкоманды default-metric устанавливается метрика для этого маршрута.

Аналогично выполняется и конфигурация маршрутизатора RTF (листинг 12.52), где

в    EIGRP    преобразуется    только   маршрут    0/0   с    применением   карты    маршрутов

DEFAULT_ONLY.

Листинг 12.52. Применение EIGRP в качестве протокола IGP (конфигурация маршрутизатора RTF)

router eigrp  1

redistribute bgp 3  route-map DEFAULT_ONLY network  172.16.0.0

default-metric 1000   100   250   100   1500

router bgp  3

no synchronization

network 172.16.50.0 mask 255.255.255.0

neighbor 172.16.70.1 remote-as 3

neighbor 172.16.70.1 next-hop-self

neighbor 192.68.5.2 remote-as 2

neighbor 192.68.5.2   filter-list 10 out no auto-summary

ip as-path access-list 10 permit  A$ access-list 5 permit 0.0.0.0

route-map DEFAULT ONLY permit 10

  match ip address   5                                                        

На маршрутизаторе RTF используется выражение default-metric 1000 100 250 100

1500, с помощью которого устанавливается метрика маршрута по умолчанию  в приемлемом для протокола EIGRP виде. Обратите внимание на часть полосы пропускания (1000), выделяемую в выражении default-metric на маршрутизаторе RTF, которая является намного большей, чем полоса пропускания, выделяемая на RTA (5). Таким образом, метрика, получаемая от RTF, намного меньше, чем получаемая от RTA.

Как показано в листинге 12.53, на маршрутизаторе RTG поддерживается только протокол EIGRP, и доступ ко всем маршрутам за пределами AS3 осуществляется через маршрут по умолчанию.

Листинг 12.53. Применение EIGRP в качестве протокола IGP (конфигурация маршрутизатора RTG)

router eigrp 1

  network 172.16.0.0                                                            

В листинге 12.53 приведена таблица IP-маршрутов на маршрутизаторе RTG. Обратите внимание, что на RTG поддерживается маршрут по умолчанию в направлении маршрутизатора RTF.

Листинг 12.54. Таблица IP-маршрутов на маршрутизаторе RTG

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP

D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR

Gateway of last resort is 172.16.50.1 to network 0.0.0.0 172.16.0.0/16 is subnetted, 4 subnets

D    172.16.220.0/24 [90/2195456] via 172.16.70.1, 00:12:17, SerialO

172.16.50.0/24 is directly connected, Seriall

D    172.16.20.0/24 [90/2681856] via 172.16.70.1, 00:12:17, SerialO

172.16.70.0/24 is directly connected, SerialO

 D*EX 0.0.0.0/0 [170/3097600] via 172.16.50.1, 00:07:40, Seriall                

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100