Маршрутизация по правилам в сети Internet

В этом разделе показано, как использовать маршрутизацию по правилам для пересылки трафика на основе IP-адреса источника, а не IP-адреса пункта назначения. На рис.показан маршрутизатор RTA, который  поддерживает работу по протоколу ВОР с провайдерами AS1 и AS2. На внутренних маршрутизаторах, таких как RTG и RTF, поддерживается только протокол IGP (в данном случае OSPF) и установлены маршруты по умолчанию в направлении RTA.

Рис. 12.12. Вариант организации маршрутизации по правилам

Итак, на маршрутизаторе RTA нужно установить такие правила маршрутизации, чтобы трафик, поступающий через интерфейс S1 от RTG направляйся бы в AS2, если он поступил из сети 172.16.10.0/24. Трафик, поступающий от RTG из сети 172.16.112.0/24, следует направлять в AS1, а в случае выхода из строя канала с провайдером — в AS2. Все остальные IP-адреса источников обрабатывать без изменений. В листинге 12.63 представлена

конфигурация маршрутизатора RTA, удовлетворяющая критериям вышеприведенных правил маршрутизации.

Листинг 12.63. Маршрутизация по правилам (конфигурация маршрутизатора

RTA)

interface EthernetO

ip address 172.16.80.1 255.255.255.0

interface Seriall

ip address 172.16.70.1 255.255.255.0

ip policy route-map CHECK_SOURCE

router ospf 10

passive-interface SerialO passive-interface EthernetO

network 172.16.0.0 0.0.255.255 area 0 default-information originate always

router bgp 3

no auto-summary

ip as-path access-list 10 permit A$

access-list 1 permit 172.16.10.0 0.0.0.255

access-list 2 permit 172.16.112.0 0.0.0.255

route-map CHECK SOURCE permit 10 match ip address 1

set ip next-hop 172.16.80.2

route-map CHECK SOURCE permit 20 match ip address 2

  set ip nexthop 172.16.20.1 172.16.80.2                                       

Маршрутизация по правилам используется всегда в отношении входящего интерфейса. Как видите, интерфейс Serial 1 настраивается с помощью команды ip policy route-map map-name. В нашем случае ко всему входящему на интерфейс Serial 1 трафику применяется карта маршрутов CHECK^SOURCE. Эта карта работает следующим образом.

·          Запись 10 – для всех IP-адресов источника, которые принадлежат сети 172.16.10.0/24, назначить следующим узлом 172.16.80.2. Если узел 172.16.80.2 недоступен, пакет отвергается.

·          Запись 20 – для всех IP-адресов источника, принадлежащих сети 172.16.112.0/24, установить в качестве следующего узла 172.16.20.1. Если узел 172.16.20.1 недоступен, то попытаться направить трафик на узел 172.16.80.2.

·          Все остальные IP-адреса обрабатываются как обычно.

В данном случае маршрутизация по правилам с помощью карт маршрутов позволяет выбирать следующий узел, на который будет пересылаться трафик.  Необходимо  всегда иметь резервный маршрут. Весь трафик, на который не распространяется действие карт маршрутов, должен обрабатываться без изменений согласно протоколу маршрутизации. Чтобы проиллюстрировать, что мы получили в результате последних манипуляций, на маршрутизаторе RTG мы задали команду traceroute 192.68.10.1 с IP-адресом источника 172.16.112.1. В листинге 12.64 представлена таблица IP-маршрутов на маршрутизаторе RTA.

Листинг 12.64. Маршрутизация по правилам (таблица маршрутов на маршрутизаторе RTA)

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP  i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR Gateway of last resort is not set

172.16.0.0/16 is subnetted, 5 subnets

O    172.16.50.0/24 [110/69] via 172.16.70.2, 00:27:27, Seriall

172.16.20.0/24 is directly connected, SerialO

172.16.80.0/24 is directly connected, EthernetO

      172.16.70.0/24 is directly connected, Seriall                             

В листинге 12.65 показан процесс выполнения команды traceroute на маршрутизаторе RTG с адресом источника 172.16.112.1 и адресом пункта назначения 192.68.10.1.

Листинг 12.65. Маршрутизация по правилам (выполнение команды traceroute на маршрутизаторе RTG)

RTG#traceroute Protocol [ip]:

Target IP address: 192.68.10.1 Source address: 172.16.112.1 Numeric display [n]:

Timeout in seconds [3]:

Probe count [3]:

Minimum Time to Live [1]: Maximum Time to Live [30]: Port Number [33434]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Type escape sequence to abort.

Tracing the route to gateway.aeg-aas.de (192.68.10.1} 172.16.70.1 4 msec 4 msec 0 msec

172.16.20.1 4 msec 4 msec 4 msec

 192.68.6.1 4 msec 4 msec 4 msec                                                

Обратите внимание, что  маршрутизатор RTA связывается с сетью 192.68.10.0/24 через промежуточный узел 172.16.20.1 (вторая строка в выводе результатов по команде traceroute). Хотя даже таблица маршрутов на RTA указывает, что в сеть 192.68.10.0/24 можно попасть через узел 172.16.80.2.

В этой второй попытке показано, что может случиться, если интерфейс Serial 0 вышел из строя, а узел 172.16.20.1 недоступен. Теперь давайте выполним команду traceroute на маршрутизаторе RTG с адресом источника 172.16.112.1 и пунктом назначения 192.68.10.1, когда интерфейс Serial 0 неактивен, как это показано в листинге 12.66.

Листинг 12.66. Маршрутизация по правилам (повторное выполнение команды

traceroute на маршрутизаторе RTG)

RTG# traceroute Protocol [ip]:

Target IP address: 192.68.10.1 Source address: 172.16.112.1 Numeric display [n]:

Timeout in seconds [3]:

 Probe count [3] :                                                              

Minimum Time to Live [1]: Maximum Time to Live [30]: Port Number [33434]:

Loose, Strict, Record, Timestamp, Verbose[none]: Type escape sequence to abort.

Tracing the route to gateway.aeg-aas.de (192.68.10.1} 172.16.70.1 0 msec 4 msec 4 msec

 172.16.80.2 8 msec 4 msec 4 msec                                               

Как видите, вывод результатов выполнения traceroute, представленный в листинге 12.66, демонстрирует, что маршрутизатор RTA выбирает альтернативный следующий узел 172.16.80.2.

Прежде  чем  приступить  к  реализации  решений  на  основе  маршрутизации  по

правилам, ознакомьтесь с документацией на вашу версию IOS и уточните, поддерживаются ли те процедуры, которые вы собираетесь использовать, и если — да, то на каком оборудовании. Кроме того, вы можете получить дополнительную информацию по этим вопросам в справочнике по командам Cisco (Cisco Guide Reference), руководстве по конфигурированию (Configuration Guidelines) и в информационных бюллетенях для вашего оборудования и версий программного обеспечения (Release Notes).

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100