Динамическое вложение информации в BGP

Рис. 11.4. Вложение маршрутов в протокол BGP

В приведенном ниже примере демонстрируется динамическое вложение маршрутной информации в протокол BGP. Рассмотрим рис. 11.4

Предположим, что AS3 подключена к сети Internet через AS1. Внутри AS3 в качестве протокола IGP используется OSPF, а с ASI она взаимодействует по EBGP. С другой стороны, у AS3 есть клиент К1, со следующими характеристиками:

•                           К1 указывает маршрут по умолчанию в направлении AS3;

•                           К1 объявляет все свои маршруты в AS3 с использованием протокола RIP.

На маршрутизаторе RTF организовано два процесса маршрутизации —OSPF и RIP. Кроме того, маршрутизатор RTF будет только ожидать появления RIP-маршрутов  через соединение с К1 и преобразовывать полученные маршруты в OSPF-маршруты. С другой стороны, на маршрутизаторе RTA также запущено два процесса — OSPF и ВОР. Маршрутизатор RTA будет динамически преобразовывать все свои локальные маршруты и маршруты, полученные от своего клиента К1, в BGP-маршруты. Все это видно из листинга 11.17.

Листинг 11.17. Преобразование маршрутов в маршрутизаторе RTF

interface Ethernetl/0

ip address 172.16.65.1 255.255.255.192

interface Etnernetl/1

ip address 172.16.1.2 255.255.255.0

interface Serial2/l

ip address 192.68.5.1 255.255.255.0

router ospf 10 redistribute rip subnets

network 172.16.0.0 0.0.255.255 area 0

router  rip

passive-interface  Serial2/l

  network  192.68.5.0                                                          

В конфигурации маршрутизатора RTF вы встретите две новых команды.

·                       passive-interface type number — запрещает пересылку обновлений маршрутов на указанный интерфейс. В приведенном примере при использовании совместно с RIP   эта   команда   не   допускает   пересылку   обновлений   RIP-маршрутов   на

интерфейс S2/1. Это необходимо в том случае, когда несколько клиентов, подключенных к маршрутизатору RTF, не должны "видеть" сети друг друга.

При работе по протоколу OSPF эта команда запрещает передачу пакетов hello на определенный интерфейс, что, в свою очередь, не допускает обмена информацией о состоянии соединения через этот интерфейс.

·                       redistribute protocol [process-id] осуществляет преобразование (подстановку) маршрутов из одного процесса маршрутизации в другой. В рассматриваемом случае в маршрутизаторе RTF RIP-маршруты преобразуются в OSPF-маршруты (процесс 10). Для команды redistribute существует огромное количество различных расширений (например, subnets). Все эти расширения будут рассмотрены позднее.

С помощью ключевого слова subnets можно удостовериться, вся ли информация о

подсетях была в точности передана процессу OSPF. Это требуется только при вложении маршрутов в протокол OSPF. Подобный случай приведен в листинге 11.18.

Листинг 11.18. Статическое преобразование маршрутов в RIP на маршрутизаторе RTD

interface Ethernetl/1

ip address 192.68.10.1 255.255.255.0

interface SerialO/0

ip address 192.68.5.2 255.255.255.0

router rip redistribute static network 192.68.5.0

network 192.68.10.0

default-metric 1

 ip route 0.0.0.0 0.0.0.0 192.68.5.1                                            

Обратите внимание, что маршрутизатор RTD сконфигурирован со статическим маршрутом по умолчанию в направлении маршрутизатора RTF. Для всех  пунктов назначения вне сети клиента К1 маршрутизатор RTD  будет направлять трафик на RTF. Кроме того, RTD будет также ретранслировать информацию о статическом маршруте по умолчанию во внутренний домен RIP, так что все остальные маршруты могут по умолчанию указывать на AS3. Команда маршрутизатора default-metric задает метрику преобразуемых маршрутов. В этом случае метрика по умолчанию устанавливается равной ], так как имеется всего один промежуточный узел для Маршрута 0/0 и этот маршрут преобразуется в RIP- маршрут. Этот случай описан в листинге 11.19.

Листинг 11.19. Преобразование OSPF-маршрутов на маршрутизаторе RTA

interface EthernetO

ip address 172.16.220.1 255.255.255.0

interface Ethernetl

ip address 172.16.1.1 255.255.255.0

interface SerialO

ip address 172.16.20.2 255.255.255.0

router ospf 10

passive-interface Serial 0

network 172.16.0.0 0.0.255.255 area 0

router  bgp 3

redistribute ospf 10 match external 1 external 2

neighbor 172.16.20.1 remote-as 1

  no auto-summary                                                               

На    маршрутизаторе    RTA    имеется    комбинация    OSPF-маршрутов,    которые

принадлежат к AS3 и к другим внешним маршрутам, поступающим из RIP-домена К1. При применении команды маршрутизатора redistribute маршрутизатор RTA будет динамически подставлять все эти маршруты в свой процесс BGP. Отметим, что в маршрутизаторе RTA с этой командой используются также ключевые слова match external I external 2, поскольку протоколом OSPF не предусмотрено вложение внешних маршрутов в BGP, если явно не указано, что он должен это делать. Это было сделано, чтобы избежать образования петель маршрутизации в тех случаях, когда информация о внешних OSPF-маршрутах может быть получена из BGP-маршрутов.

В листинге 11,20 показан фрагмент таблицы IP-маршрутов на маршрутизаторе RTA

после выполнения вышеуказанных действий.

Листинг 11.20. Таблица маршрутов маршрутизатора RTA

RTA#show ip route

Codes:– connected, S — static, I – IGRP, R – RIP  M — mobile,  – BGP, D – EIGRP, EX – EIGRP

external,  — OSPF, IA – OSPF inter area

Обратите внимание, что в таблице IP-маршрутов маршруты в сети 192.68.10.0/24 и 192.68.5.0/24 описаны как внешние OSPF-маршруты (О Е2). Динамическое преобразование приведет к тому, что маршруты в эти сети будут вложены в BGP. В листинге 11.21 представлен внешний вид таблицы BGP-маршрутов на маршрутизаторе RTC после преобразования.

Листинг 11.21. Таблица BGP-маршрутов на маршрутизаторе RTC

RTCttshow ip bgp

BGP table version is 20, local router ID is 192.68.11.1

Status codes: s suppressed, d damped, h history, * valid, > best,

Обратите внимание, что все маршруты к сетям в AS3, где поддерживается OSPF, становятся BGP-маршругами в AS1. В BGP нужно передавать сведения не обо всех сетях, принадлежащих к вашей AS. Дело в том, что довольно часто внутри AS имеются сети с общедоступными IP-адресами или используются IP-адреса, незарегистрированные официально. Нельзя допустить, чтобы эти данные попадали во внешние сети. Посмотрите, каким образом проводится преобразование в BGP адреса петли 172.16.2,254/32. Провайдеры

обычно не разрешают объявление столь длинных префиксов (например, /32) и настаивают, чтобы вы их фильтровали или сами фильтруют их на своих узлах. Это ограничение вводится с целью сдерживания роста глобальных таблиц IP-маршрутов. Нет необходимости и в преобразовании в ВОР сведений о сети 172.16.20.0/24, которая является зоной демилитаризации (demilitarized zone — DMZ). Вот почему совместно с преобразованием маршрутов следует использовать фильтрацию. Благодаря этому вы сможете точно определить маршруты, которые следует объявлять.

Маршрутизатор   RTA,   сконфигурированный,   как   показано   в   листинге   11.22,

позволяет выполнить такую фильтрацию.

Примечание

Начиная с этого момента и далее в целях экономии места мы будем рассматривать в листингах

только те команды, которые непосредственно связаны с обсуждаемой темой.

Листинг 11.22. Фильтрация преобразуемых маршрутов

router ospf 10

passive-interface SerialO

network 172.16.0.0 0.0.255.255 area 0

router bgp  3

redistribute ospf 10 match external  1  external 2

neighbor 172.16.20.1 remote-as   1

neighbor 172.16.20.1 route-map BLOCKROUTES out

no auto-summary

access-list 1

permit

172.16.2.254  0.0.0.0

access-list 1

permit

172.16.20.0   0.0.0.255

route-map BLOCKROUTES deny 10 match  ip address 1

 routemap BLOCKROUTES permit 20                                                

Фильтрация в листинге 11.22 выполняется с помощью карты маршрутов, которая определяет набор действий, предпринимаемых в случае необходимости анализа ситуации на основе определенного критерия. Критериями в нашем случае является выявление соответствия маршрута на хост 172.16.2.254/32 и к сети 172.16.20.0/24, чтобы не допустить их вложения в BGP. В списке разрешения доступа access-list 1 вы можете найти соответствия этим маршрутам, а команда route-map BLOCKROUTES определяет дальнейшие действия (в нашем случае маршруты должны быть отвергнуты). Вторая запись в карте (20) разрешает преобразование всех остальных маршрутов в BGP. (Если нужно более детальное описание этого процесса, обратитесь к главе 6, где обсуждалась фильтрация).

В листинге 11.23 представлено, как будет выглядеть таблица BGP-маршрутов на маршрутизаторе RTC после фильтрации. Как видите, маршруты на хост 172.16.2.254/32 и в сеть 172.16.20.0/24 отсутствуют.

Листинг 11.23. Таблица BGP-маршрутов на маршрутизаторе RTC после фильтрации

RTC#show ip bgp

BGP table version is 34, local router ID is 192.68.11.1

Status  codes:  s  suppressed,  d  damped,  h  history,  *  valid,  >  best

Чтобы  лучше  контролировать,  что  преобразуется  из  ЮР  в  ВОР  вы  можете

использовать команду network. Команда network — еще один способ отдельно задавать префиксы, которые нужно пересылать по ВОР. С помощью этой команды указывается префикс, который будет пересылаться дальше (адрес сети и ее маска). Например, выражение network 172.16.1.0 mask 255.255.255.0 говорит о том, что должен пересылаться префикс 172.16.1.0/24. С сетями, которые приходятся на опорные связки (типа 255.0.0.0, 255.255.0.0 или 255.255.255.0), указывать маску не обязательно. Так, например, чтобы послать сведения о префиксе 172.16.0.0/16 достаточно выражения network 172.16.0.0. Такого рода сети выводятся в таблице BGP-маршрутов без префикса /х. Например, сеть класса С с адресом 192.68.11.0 может быть записана как 192.68.11.0/24.

Согласно схеме, представленной на рис. 11.4, в конфигурации маршрутизатора RTA

будут указаны адреса сетей, преобразуемые в ВОР (листинг 11.24).

Листинг 11.24. Конфигурация маршрутизатора RTA, где задаются адреса сети, требующие преобразования в BGP

router ospf 10

passive-interface SerialO

network 172.16.0.0 0.0.255.255 area 0

router bgp  3

network 172.16.1.0 mask 255.255.255.0

  no auto-summary                                                              

В листинге 11.25 показан внешний вид таблицы BGP-маршрутов на маршрутизаторе

RTC после выполнения описанных действий.

Листинг 11.25. Таблица BGP-маршрутов на маршрутизаторе RTC

RTC#show  ip bgp

BGP  table  version   is  34,  local  routerID  is   192.68.11.1

Status codes: s suppressed, d damped, h history, * valid, > best,

i – internal Origin codes: i – IGP, e – EGP, i – incomplete

Network                 Next Hop      Metric      LocPrf     Weight  Path

  *>   192.68.11.0        0.0.0.0      0                       32768   i      

Итак, в BGP преобразуются все маршруты, кроме 172.16.2.254/32 и 172.16.20.0/24. Обратите внимание, что таблица BGP-маршрутов очень похожа на ту, которая была сформирована после преобразования OSPF-маршрутов в BGP-маршруты и применения к ним фильтров. Единственная заметная разница заключается в коде источника i, который ставится в конце записи с информацией о маршруте. Код источника i означает, что источник сведений об этих сетях — внутренний по отношению к AS (в данном случае это протокол IGP). Если вы просмотрите еще раз предыдущий снимок таблицы BGP-маршрутов, сделанный с BGP- маршрутизатора (листинг 11.23), то увидите, что в нем указывается код источника ?, т.е. незавершенный. Это говорит о том, что сведения об этих сетях были получены какими-то другими средствами. Маршруты, поступающие в BGP после преобразования, будут иметь незавершенный код источника, если явно не указано другое.

Команда network действует только в том случае, если заданные в ней префиксы известны маршрутизатору. Другими словами, в BGP невозможно объявлять префиксы вслепую, только на основании того, что они указаны в команде. Прежде чем объявить тот или иной префикс, маршрутизатор сопоставит его с содержимым таблицы IP-маршрутов. Так, в листинге 11.25, если вы задаете команду network 172.16.192.0 mask 255.255.255.0,

маршрут в эту сеть не будет сгенерирован, так как она не известна маршрутизатору.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100