Атрибуты BGP

В этом разделе мы будем работать с топологией сети, представленной на рис. 11.6, которая поможет нам выяснить, как работают различные атрибуты протокола BGP.

В листингах 11.30—11.33 представлены базовые конфигурации маршрутизаторов

RTA, RTF, RTC и RTD. Дополнительные настройки мы будем вносить по мере обсуждения отдельных атрибутов.

Рис.11. 6. Применение атрибутов BGP

Листинг 11.30. Базовая конфигурация маршрутизатора RTA (рис. 11.6)

ip subnet-zero

interface LoopbackO

ip address 172.16.2.254 255.255.255.255

interface EthernetO

ip address 172.16.220.1 255.255.255.0

interface Ethernetl

ip address 172.16.1.1 255.255.255.0

 interface SerialO                                                              

ip address 172.16.20.2 255.255.255.0

router ospf 10

passive-interface SerialO

network 172.16.0.0 0.0.255.255 area 0

router bgp 3

no synchronization

network 172.16.1.0 mask 255.255.255.0

network 172.16.10.0 mask 255.255.255.0

network 172.16.65.0 mask 255.255.255.192

network 172.16,220.0 mask 255.255.255.0

neighbor 172.16.1.2 remote-as 3

neighbor 172.16.1.2 update-source LoopbackO neighbor 172.16.20.1 remote-as 1

neighbor 172.16.20.1 filter-list 10 out no auto-summary

ip classless

ip as-path access-list 10 permit A$

Листинг 11.31. Базовая конфигурация маршрутизатора RTF (рис. 11.6)

ip subnet-zero interface EthernetO/0

ip address 172.16.10.1 255.255.255.0

interface Ethernet 1/0

ip address 172.16.65.1 255.255.255.192

interface Ethernetl/1

ip address 172.16.1.2 255.255.255.0

interface Serial2/l

ip address 192.68.5.1 255.255.255.0

router ospf 10

network 172.16.0.0 0.0.255.255 area 0

router bgp 3

no synchronization

network 172.16.1.0 mask 255.255.255.0

network 172.16.10.0 mask 255.255.255.0

network 172.16.65.0 mask 255.255.255.192

network 172.16.220.0 mask 255.255.255.0

neighbor 172.16.2.254 remote-as 3

neighbor 192.68.5.2 remote-as 2

neighbor 192.68.5.2 filter-list 10 out no auto-summary

ip classless

ip as-path access-list 10 permit A$

Листинг 11.32. Базовая конфигурация маршрутизатора RTC (рис. 11.6)

ip subnet-zero interface EthernetO/0

ip address 192.68.11.1 255.255.255.0

interface EthernetO/1

ip address 192.68.6.2 255.255.255.0

interface Serial2/l

ip address 172.16.20.1 255.255.255.0

router bgp 1

network 192.68.11.0

neighbor 172.16.20.2 remote-as 3

  neighbor 192.68.6.1 remote-as 2                                               

no auto-summary

 ip classless                                                                   

Листинг 11.33. Базовая конфигурация маршрутизатора RTD (рис. 11.6)

ip subnet-zero interface Ethernetl/0

ip address 192.68.10.1 255.255.255.0

interface Ethernetl/1

ip address 192.68.6.1 255.255.255.0

interface SerialO/0

ip address 192.68.5.2 255.255.255.0

router bgp 2

network 192.68.10.0

neighbor 192.68.5.1 remote-as 3

neighbor 192.68.6.2 remote-as 1 no auto-suranary

 ip classless                                                                   

Предположим также, что AS3 не является транзитной. Именно поэтому задается команда filter-list 10, которая заставляет генерировать AS3 только локальные маршруты. Маршруты, полученные от AS1 и AS2, не будут распространяться вне AS3. Отметим также, что некоторые сети, такие как 172.16.10.0/24, объявляются с помощью команды network как на маршрутизаторе RTA, так и на маршрутизаторе RTF. Так можно проверить, будут ли объявляться эти сети при отсутствии связи между AS3 и AS1 или AS3 и AS2.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100