Атрибут MULTU_EXIT_DISC – Атрибуты BGP

В этом разделе мы рассмотрим, как использовать метрики одной AS, чтобы повлиять на процесс принятия решения о выборе маршрута в другой AS. Это осуществляется с помощью атрибута MULTI_EXIT_DISC (сокращенно MED). На рис. 11.8 AS3 является клиентом  провайдера  AS1.  Для  того  чтобы  влиять  на  входящий  трафик,  нужно  в  AS3

генерировать набор метрик и отсылать его в AS1, Если все BGP-атрибуты одинаковы, в протоколе BGP будет отдаваться предпочтение тем маршрутам, которые имеют меньшую метрику по сравнению с другими.

На маршрутизаторах RTA и RTF поддерживается для внутреннего обмена протокол

IBGP, а для работы с провайдером AS1 — протокол EBGP. Маршрутизатор RTG является внутренним и поддерживает только протокол OSPF. Предположим, что маршрутизаторы RTA и RTF должны в направлении AS1 посылать MED для достижения следующих целей.

·                       Пересылать входящий трафик для сети 172.16.1.0/24 по каналу SF.

·                       Входящий трафик для остальных сетей пересылать с применением граничного маршрутизатора, который обладает  информацией о маршрутах в эти  сети с меньшими внутренними метриками. Например, входящий трафик в направлении сети 172.16.112.0/24 должен пересылаться по каналу SF, если у RTA есть маршрут с меньшей метрикой к этой сети, чем у RTF.

Рис. 11.8. Установка атрибута MED

В листингах 11.45 и 11.46 показаны конфигурации маршрутизаторов RTA и RTF,

удовлетворяющие указанным критериям.

Листинг 11.45. Установка атрибута MED – конфигурация маршрутизатора

RTA

router ospf 10

passive-interface SerialO

network 172.16.0.0 0.0.255.255 area 0

router bgp 3

no synchronization

network 172.16.1.0 mask 255.255.255.0

network 172.16.10.0 mask 255.255.255.0

network 172.16.65.0 mask 255.255.255.192

network 172.16.220.0 mask 255.255.255.0

network 172.16.112.0 mask 255.255.255.0

neighbor 172.16.1.2 remote-as 3

neighbor 172.16.1.2 update-source LoopbackO

neighbor 172.16.20.1 remote-as 1

neighbor 172.16.20.1 filter-list 10 out

no auto-summary

ip as-path access-list 10 permit A$

Листинг 11.46. Установка атрибута MED — конфигурация маршрутизатора RTF

router ospf 10

network 172.16.0.0 0.0.255.255 area 0

router bgp 3

no synchronization

network 172.16.1.0 mask 255.255.255.0

network 172.16.10.0 mask 255.255.255.0

network 172.16.65.0 mask 255.255.255.192

network 172.16.220.0 mask 255.255.255.0

network 172.16.112.0 mask 255.255.255.0

neighbor 172.16.2.254 remote-as 3

neighbor 172.16.2.254 next-hop-self

neighbor 192.68.5.2 remote-as 1

neighbor 192.68.5.2 route-map SETMETRIC out

neighbor 192.68.5.2 filter-list 10 out no auto-summary

ip as-path access-list 10 permit A$ access-list 1 permit 172.16.1.0 0.0.0.255

route-map SETMETRIC

permit 10 match ip address 1

set metric 50

  route-map SETMETRIC permit 20                                                 

Маршрутизатор RTF, сконфигурированный, как показано в листингах 11.45 и 11.46, будет генерировать префикс 172.16.1.0/24 с MED равным 50. Получив сведения об этом префиксе, ASI сравнивает метрику 50 с метрикой 0, поступающей от маршрутизатора RTA, и, естественно, будет задействовать канал SF. Все остальные сети будут объявляться в BGP с внутренними метриками, и AS1 будет выбирать ту точку входа, которая обладает наименьшей метрикой. В листинге 11.47 представлена BGP-таблица на маршрутизаторе RTD после внесения описанных изменений.

Листинг 11.47. BGP-таблица на маршрутизаторе RTD

RTC# show ip bgp

BGP table version   is  34,  local  routerID  is   192.68.11.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal Origin codes: i – IGP, e – EGP, i – incomplete

Network                Next Hop     Metric      LocPrf     Weight Path

  *> i192.68.11.0        192.68.6.2   0           100        0      i        

Посмотрите как в таблице BGP-маршрутов, приведенной в листинге 11.47, выбирается маршрут в сеть 172.16.1.0/24 через узел 192.68.6.2, т.е. через маршрутизатор RTC (он использует самого себя как следующий узел с помощью команды next-hop-self). Этот маршрут выбирается благодаря тому, что имеет меньшую метрику (0 меньше 50). Для всех остальных сетей маршрутизатор RTD также будет использовать маршруты с наименьшими метриками. Обратите внимание, что сведения о сети 172.16.112.0/24 получены от маршрутизатора RTA по маршруту с метрикой 74, а от маршрутизатора RTF — с метрикой

84. Таким образом, чтобы доставить данные в сеть 172.16.112.0/24, маршрутизатор RTD будет передавать их по каналу SF.

Для маршрутов, сведения о которых были получены посредством BGP, имеется возможность пересылки в другую AS с внутренними метриками IGP, перенесенными при преобразовании маршрутов в BGP-маршруты. Это выполняется с помощью команды set metric-type internal, которая описывает часть карты маршрутов в направлении соседнего узла. Таким образом, BGP-маршруты будут переносить в атрибуте MED информацию о внутренних метриках протокола IGP.

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100