Применение IGRP в качестве протокола IGP – правила маршрутизации в сети Internet

В протоколе IGRP не поддерживается маршрут по умолчанию 0.0.0.0. Чтобы установить в IGRP маршрут по умолчанию, необходимо на маршрутизаторах RTA и RTF задать глобальную команду ip default-network. Эта сеть по умолчанию должна переводиться под управление IGRP и устанавливать на внутренних маршрутизаторах маршруты по умолчанию. Для успешного преобразования ей нужно задать метрику по умолчанию.

Как видно из конфигурации маршрутизатора RTA, приведенной в листинге 12.55, в

нем в качестве сети по умолчанию устанавливается сеть 192.68.6.0/24 (или любая другая классовая сеть, сведения о которой получены по BGP). Далее на RTA эта сеть переводится под управление IGRP.

Листинг 12.55. Применение IGRP в качестве протокола IGP (конфигурация маршрутизатора RTA)

router igrp 1

passive-interface SerialO

redistribute bgp 3 route-map DEFAULT_ONLY network 172.16.0.0

default-metric 5 100 250 100 1500

router bgp 3

no synchronization

network 172.16.70.0 mask 255.255.255.0

network 172.16.220.0 mask 255.255.255.0

neighbor   172.16.20.1   remote-as   1

neighbor 172.16.20.1 filter-list 10 out

neighbor 172.16.50.1 remote-as   3

neighbor   172.16.50.1 route-map  setlocalpref in no auto-summary

Как видно из конфигурации маршрутизатора RTF, представленной в листинге 12.56, на нем также устанавливается маршрут по умолчанию в сеть 192.68.6.0/24 и преобразуется с лучшей метрикой в IGRP.

Листинг 12.56. Применение IGRP в качестве протокола ЮР (конфигурация маршрутизатора RTF)

router  igrp 1

redistribute bgp  3  route-map DEFAULT_ONLY

network  172.16.0.0

default-metric 1000   100 250  100   1500

router bgp  3

no   synchronization

network 172.16.50.0 mask 255.255.255.0

neighbor 192.68.5.2 filter-list 10 out no auto-summary

ip  default-network 192.68.6.0

ip as-path access-list 10 permit  A$

access-list 5  permit 192.68.6.0   0.0.0.255 route-map DEFAULT_ONLY permit 10

  match ip address   5                                                        

Как видите, на маршрутизаторе RTG поддерживается только протокол IGRP и маршрут по умолчанию за пределы AS3 (листинг 12.57).

Листинг 12.57. Применение IGRP в качестве протокола ЮР (конфигурация маршрутизатора RTG)

router  igrp  1

  network  172.16.0.0                                                          

В листинге 12.58 представлена таблица IP-маршрутов на маршрутизаторе RTG. Как видите, на RTG установлен маршрут по умолчанию в направлении RTF.

Листинг 12.58. Таблица IP-маршрутов на маршрутизаторе RTG

RTA#show ip route

Codes:  – connected, S – static, I – IGRP, R – RIP, M – mobile,  -BGP D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 El – OSPP external type 1, E2 — OSPF external type 2, E – EGP  i – IS-IS, LI – IS-IS level-1, L2 – IS-IS level-2,

* – candidate default U – per-user static route,  – ODR Gateway of last resort is 172.16.50.1 to network 192.68.6.0

I*  192.68.6.0/24 [100/8576] via 172.16.50.1, 00:00:32, Seriall

172.16.0.0/16 is subnetted, 4 subnets

I    172.16.220.0/24 [100/8576] via 172.16.70.1, 00:00:32, SerialO

172.16.50.0/24 is directly connected, Seriall

I    172.16.20.0/24 [100/10476] via 172.16.70.1, 00:00:32, SerialO

      172.16.70.0/24 is directly connected, SerialO                             

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100