Мультипротокольные расширения BGP (Multiprotocol BGP — MBGP)

Вместе с поддержкой функций БGP (BGP Capabilities – BGPCAP1 в мультипротокольном расширении для протокола BGP (Multiprotocol BGP – MBGP:) описываются и обратно совместимые дополнения для протокола BGP-43, которые позволяют ему передавать маршрутную информацию для нескольких протоколов сетевого уровня, (например, IPv6, IPX и т. п.). Отдельные протоколы сетевого уровня идентифицируются семейством адресов (address family — AF), как описано в RFC 17004. Эти расширения позволяют набору BGP-узлов обмениваться информацией о взаимной доступности для различных семейств адресов (например, IPv4, IPv6, IPX и т. п.), а также у  подсемейств адресов (уникальные или групповые IP-адреса).

Примечание

Полный переход от старого интерфейса командной строки к новому, ориентированному на семейства адресов, пока еще не полностью реализован в оборудовании компании ^ Cisco. Поэтому если вы встретитесь с какими-либо противоречиями, проконсультируйтесь с персоналом из отдела технической поддержки компании Cisco или обратитесь к документации для вашей версии Gisco-IOS.

Причины перехода к новому интерфейсу командной строки

Существование нескольких семейств адресов обусловило развитие нескольких параллельных топологий, которые в итоге привели бы к полной взаимной несовместимости. Кроме того, наборы правил маршрутизации, задаваемые в определенном сеансе могут видоизменяться в зависимости от семейства адресов (address family— AF). Начальный интерфейс командной строки (Command Line Interface — CLI) был разработан для обслуживания только одного AF (IPv4) и был связан лишь с обработкой двух подсемейств адресов уникальныХ’И групповых адресов (unicast and multicast). В  результате использования этого интерфейса’для поддержки дополнительных АР усложнились выражения, описывающие правила маршрутизации, а также повысились затраты на обслуживание этих AF.

Тогда был предложен новый подход — четкое отделение основных параметров сеанса работы маршрутизатора от специфических параметров, присущих определенному AF. Кроме отдельных аспектов управления, новый подход обеспечивает и другие преимущества.

·          Входные и выходные правила маршрутизации могут отличаться для различных AF.

·          BGP-маршрутизатор может быть настроен как отражатель маршрутов для одного AF

или сразу нескольких AF.

·          Не требуется дополнительных усилий для конфигурации и поддержки "ванильного"

BGP (IPv4 с уникальными адресами).

·          Префиксы могут независимо поступать из любых источников (путем преобразования, выражений aggregate-address и выражений network) внутри каждого AF.

·          Группы взаимодействующих узлов будут обслуживаться внутри соответствую щего

AF, так как это касается генерации сообщений UPDATE.

Новая модель более гибкая при использовании нескольких семейств адресов. На основе приведенных выше преимуществ субкоманды router bgp можно разделить на три группы,

1.        Глобальные   команды   BGP   —   влияют   на   работу   протокола   BGP   во   всем

маршрутизаторе. Например, это такие команды, как bgp deterministic-med и bgp cluster-id.

2.        Команды для идентификации соседних узлов/групп узлов — описывают соседние

узлы  или  группы  взаимодействующих  узлов,  которые  по  умолчанию  доступны

согласно таблице маршрутов, путем определения параметров сеанса работы с ними. Примерами таких команд могут служить команды neighbor 1.2.3.4 remote-as as и neighbor 1.2.3.4 ebgp-multihop /7/.

3.        Команды для семейств адресов — к этому типу могут быть отнесены два набора

команд:

·                                                          глобальные команды семейств адресов — это те команды, которые не зависят от конфигурации соседних узлов и влияют на работу по протоколу BGP определенного AF. Префиксы могут поступать от различных источников (с использованием преобразования, выражений network или aggregate- address) для AF, относящегося к этой категории. Примеры таких команд: network 1.2.0.0 mask 255.255.0.0, redistribute dvmrp и bgp scan-time.

·                                                          специфические команды семейств адресов для соседних узлов/группы узлов – Эти команды позволяют настроить правила работы с соседними узлом (узлами) или в группе взаимодействующих узлов с помощью списков преобразования, списков префиксов или карт маршрутов. Соседние узлы можно также конфигурировать как клиентов отражателя маршрутов или как дополнительных членов группы узлов. При этом соседние узлы должны быть явным образом "активированы" в целях разрешения обмена префиксами в рамках MBGP. Подобными командами являются neighbor 1.2.3.4 filter-list in, neighbor peergroupl route map foo in и neighbor 1.2.3.4 activate.

Организация групп команд в новой конфигурации

Для группы команд 1 отсутствует неоднозначность, так что они могут задаваться в качестве глобальных параметров BGP. Эти команды задаются при конфигурации узлов только один раз.

Отсутствует неоднозначность и для команд группы 2, которые следуют  за командами группы 1 с глобальными параметрами BGP. Соседние BGP-узлы, за исключением случая виртуальных  частных сетей (Virtual Private Networks — VPN), описываются при конфигурации лишь один раз.

В режим конфигурации с использованием команды router bgp autonomous-system

был введен новый дополнительный режим для команд AF.

При использовании нового AF-ориентированного интерфейса командной строки конфигурация представляет собой примерно следующее:

router bgp  utonomous-system

address-family   afi  [sub-afi] redistribute protocol neighbor  1.2.3.4  activate

exit-address-fainily

exit

Соседний узел по отношению к другому узлу может применять несколько различных правил маршрутизации (например, выражения route-map или prefix-list) одно для каждого AF.

Конфигурация BGP на основе IPv4 с уникальными адресами позволяет, чтобы наборы правил маршрутизации для соседних узлов были сконфигурированы лишь на основе команд группы 2. Это очень напоминает ситуацию, которую мы имеем сегодня (старый CLI). Хотя рекомендуется явная конфигурация, команда address-family ipv4 unicast также является однозначной.

Возможно сконфигурировать правила маршрутизации BGP для IPv4 с уникальными

адресами в режиме address-family. Задав команду, мы получим результат выполнения команды address-family ipv4 unicast, глобальные IPv4 с уникальными адресами (глобальные по AF) и команды формирования правил маршрутизации (специфичные для AF для соседних узлов/групп узлов), разрешенные в этом режиме.

В режиме address-family глобальные для группы AF команды задаются в первую очередь. Все эти команды являются глобальными по отношению к AF.

За глобальными командами AF задаются специфичные для AF команды для соседних узлов/групп узлов. Эти команды реализуют наборы правил маршрутизации для соседних узлов в определенном AF.

Прежде чем для соседнего узла будут описаны какие-либо правила в соответствии с заданным AF, его следует "активировать" для данного AF. Синтаксис команды для активации соседнего узла в определенном AF таков:

router bgp autonomous-system

address-family   afi  [sub-afi]

neighbor   1.2.3.4  activate

exit-address-family exit

Новая структура конфигурации представляет собой следующее:

router bgp  1

no synchronization                      ! Global to BGP

bgp deterministic-mod                  ! Global to BGP

bgp bestpath med confed                ! Global to BGP

neighbor ebgp peer-group                ! Peer group defn., global to BGP neighbor 1.1.1.1 remote-as 2            ! Neighbor defn., global to BGP neighbor 2.2.2.2 remote-as 1            ! Neighbor defn., global to BGP neighbor 3.3.3.3 remote-as 3            ! Neighbor defn., global to BGP

!

address-family ipv4 unicast     ! Address-family IPv4 u           r                                                                                                                                                        i                                                                                                                                                        i                                                                                                                                                        c                                                                                                                                                        a                                                                                                                                                        s           t                                        bgp scan-time 45                           ! Global  to IPv4-unicast aggregate-address 50.0.0.0 255.255.0.0   ! Global   to  IPv4-unicast

neighbor ebgp activate                  ! Activate neighbor for  IPv4-unic neighbor ebgp route-map ucast-out out  ! Peergroup IPv4-unicast policy neighbor 1.1.1.1 activate              ! Activate neighbor for IPv4-unic neighbor 1.1.1.1 peer-group ebgp        ! Neighbor membership – IPv4-unic neighbor 1.1.1.1 route-map ucast-in in ! Neighbor IPv4-unicast policy neighbor 2.2.2.2 activate              ! Activate neighbor for IPv4-unic neighbor 2.2.2.2 route-reflector-client ! RR client – IPv4-unicast neighbor 3.3.3.3 activate              ! Activate neighbor for IPv4-unic

neighbor 3.3.3.3 peer-group ebgp        ! Neighbor membership – IPv4-unic

no auto-summary                        ! Disable IPv4-unicast auto summarization

exit-address-famlly                    ! Exit AF sub-mode

!

address-family ipv4 multicast          ! AF sub-mode

network 100.0.0.0 mask 255.255.0.0      ! Global to IPv4-multicast redistribute dvmrp route-map redist-map ! Global to IPv4-multicast  neighbor ebgp activate                  ! Activate neighbor for IPv4-mult neighbor 1.1.1.1 peer-group ebgp        ! Neighbor membership – IPv4-mult neighbor 1.1.1.1 route-map mcast-in     ! Neighbor IPv4-multicast polic neighbor 3.3.3.3 peer-group ebgp         ! Neighbor membership        IPv4- mult

exit-address-family                    ! Exit AF sub-mode

exit

В последующих разделах приводится более подробная информация о командах. В каждом разделе приводятся два стиля конфигурации:

·                               Старый стиль — Используемый в настоящее время способ конфигурации BGP 12.0S.

·                               Стиль AF –     Новый способ конфигурирования  BGP с  применением режима

address-family.

В приведенных далее разделах рассматриваются основные этапы конфигурации — активация узла, объявление сети, групп взаимодействующих узлов, создание карт маршрутов, преобразование маршрутов, отражение маршрутов и объединение (агрегация).

activate

Команда activate лишь недавно введена в Cisco IOS в качестве расширении AF CLI. Она применяется для разрешения (или активации) поддержки указанного AF на BGP-yaie. В этом разделе будет рассмотрен старый метод разрешения использования  AF с соседним

узлом, а затем — этапы конфигурации этой же ф>гнкции с использованием нового метода.

Старый стиль

В версии 12.OS команды activate не было. Соседние узлы активировались для работы с IPv4 по BGP автоматически. Однако при разрешении использования MBGP в команде neighbor требуется указать ключевое слово nlri:

Router (confiq-router)#neighbor 1.2.3.4 remote-as 10 nlri unicast multicast

Если ключевое слово nlri не указано, то маршрутизатор будет обмениваться только префиксами IPv4. Если же оно было укзано только с параметром multicast, то обмен будет проводиться только групповыми NLRI по IPv4. Таким образом, вы получаете возможность активировать только обмен уникальными, групповыми адресами или теми и другими одновременно.

Стиль AF

Чтобы разрешить использование определенного AF между соседними узлами, на

BGP-маршрутизаторе нужно задать команду activate или перейти в режим конфигурации address-family. При этом соседние BGP-узлы автоматически активируются для работы с IPv4. Для всех остальных AF соседние узлы следует активировать явным образом. Чтобы запретить соседнему узлу работать с AF, задайте команду активации с ключевым словом по. Ниже приводится синтаксис команды, которая разрешает узлу с адресом 1.2.3.4 поддержку групповых адресов IPv4:

Router (config-router)#address-family ipv4  multicast

Router (config-router-af)#neighbor  1.2.3.4  activate

network

Теперь команду network можно задавать в соответствии с определенным AF в порядке аннексирования сети в указанном AF. В этом разделе мы рассмотрим старый и новый стили конфигурирования маршрутизатора с помощью команды network.

Старый стиль

Старый стиль применения команды network предполагает объявление сети в ВОР. В команде может дополнительно указываться расширение nlri, которое объявляется как поддерживающее работу с уникальными, групповыми или и теми, и другими адресами. Отсутствие в команде ключевого слова nlri автоматически означает, что поддерживается только работа с уникальными адресами IPv4. Например:

Router

(config-router)#bgp  10

Router

Router Router

(config-router)#network 2.2.2.0 mask 255.255.255.0

(config-router)#network 3.0.0.0 mask 255.0.0.0   nlri

(config-router)#network  1.1.0.0  mask  255.255.0.0

multicast

nlri    unicast

multicast

Стиль AF

Согласно этому стилю, наличие режима address-family устраняет необходимость использования ключевого слова nlri. Чтобы объявить сеть через IPv4, команда должна быть указана на маршрутизаторе в режиме конфигурации ВОР. Чтобы сеть была объявлена как групповая NLRI, команду network следует указывать в режиме AF с параметрами ipv4 multicast.

Приведенные ниже команды объявляют сеть всем соседним узлам семейства адресов

IPv4:

Router (config-router)#network

1.1.0.0 mask

255.255.0.0

Router (config-router}#network

2.2.2.0 mask

255.255.255.0

Чтобы объявить сеть семейства групповых адресов IPv4, нужно определить сеть для использования с AF групповых адресов IPv4:

Router  (config-router)#address-family  ipv4 multicast

Router  (config-router-af)#network  1.1.0.0 mask  255.255.0.0

Router  (config-router)#network   2.2.2.0   mask  255.255.255.0

Таким  образом,  сети  могут  независимо  объявляться  как сети  с  уникальными, групповыми или теми и другими адресами IPv4 NLRI одновременно.

Группы взаимодействующих узлов

Группы взаимодействующих узлов также теперь можно конфигурировать для специфических AF, обеспечивая вместе с тем большую гибкость по сравнению со старым стилем конфигурирования. В этом разделе мы обсудим и старые, и новые методы конфигурации групп взаимодействующих узлов.

Старый стиль

Группа взаимодействующих узлов описывалась на маршрутизаторе в режиме конфигурации BGP. Для разрешения обмена групповыми префиксами внутри группы использовалось ключевое слово nlri. С помощью ключевого слова nlri можно было указывать уникальные и групповые адреса. Если же это слово не указывалось, то поддерживались только уникальные адреса IPv4.

Члены группы узлов автоматически поддерживали уникальные иди групповые адреса — в соответствии с тем, что было задано для группы. Приведенный ниже синтаксис команды показывает, как конфигурировались группы взаимодействующих узлов старым методом:

Router  {config-router)#bgp 10

Pouter   (config-router)#neighbor   external   peer-group nlri   unicast multicast

Router  (config-rcuter)#neighbor  1.2.3.4  remote-as  20

Router  (config-router)#neighbor  1.2.3.4  peer-group external

Стиль AF

Группы узлов (или их члены) описываются на маршрутизаторе в режиме конфигурирования ВОР. Но поскольку имеются дополнительные режимы конфигурирования для различных AF, отпадает необходимость в использовании ключевого слова nlri- Группа узлов должна теперь активироваться в AF групповых адресов IPv4, что позволит проводить обмен групповыми префиксами IPv4. Как и с командой neighbor, группа взаимо-дсисптощнх узлов и ее члены по умолчанию активируются только для поддержки \нн-кольных адресов IPv4. Однако это действие можно перекрыть, задав команду activate с ключевым словом по. Следующий синтаксис команд показывает, каким образом конфигурируется группа узлов с использованием нового AF-ориентированного CLI:

Router Router

(config-router}#bgp  10

(config-router)#neighbor

external

peer-group

Router

(config-router)#neighbor

1.2.3.4

remote-as 20

Router

(config-router)#neighbor

1.2.3.4

peer-group external

Router (config-router)#address-family   ipv4  multicast

Router (config-router-af)#neighbor external  activate outer

Router (config-router-af)#neighbor  1.2.3.4 peer-group external

Карты маршрутов

Старый метод, конфигурирования карт маршрутов требовал, чтобы правила лля все отдельных AF описывались внутри одной карты маршрутов. Новый AF-ориентированный стиль конфигурации позволяет создавать индивидуальные карты маршрутов для каждого семейства адресов. В этом разделе мы остановимся на старом и новом методах описания и

применения карт маршрутов относительно различных AF.

Старый стиль

В старом стиле одна карта маршрутов использовалась для описания правил маршрутизации для всех AF. Затем эта карта маршрутов применялась либо ко входящему, либо к исходящему трафику отдельного узла или группы узлов. Правила маршрутизации для двух AF, которые могли передаваться в сеансе BGP одновременно (уникальные и групповые адреса IPv4), были представлены в одной карте маршрутов путем указания ключевого выражения match nlri в последовательности карты маршрутов. Выражение match nlri в карте маршрутов семантически выглядело так:

match nlri multicast        !  Matches only IPv4 multicast match nlrimulticast unicast !  Matches both IPv4 unicast and multicast

match nlri unicast         !  Matches only IPv4 unicast

match nlri                 !  [Unspecified; matches only IPv4 unicast

В приведенном ниже примере показано, как сконфигурировать BGP, чтобы от узла

1.1.1.1            принимались любые групповые маршруты, соответствующие списку разрешенных узлов 1:

router bgp 109

neighbor 1.1.1.1 remote-as 1 nlri unicast multicast neighbor 1.1.1.1 route-map filter-mcast in

!

route-map filter-mcast permit 10 match nlri multicast

match ip address 1

Стиль AF

Одной из важнейших причин для перехода от старого стиля конфигурации к AF- ориентированному стилю было выражение правил маршрутизации с применением ключевого выражения match nlri, которое включалось в последовательность карты маршрутов и становилось практически неуправляемым, особенно при описании сложных и специфических правил для различных AF. Благодаря поддержке в новой 1OS большего числа AF, стало очевидным, что необходимо разработать более масштабное решение для поддержки всех правил маршрутизации. Применение одной карты маршрутов для выражения всех правил маршрутизации было признано нецелесообразным и очень сложным.

Представление нового режима анализа для каждого отдельного AF способствовало введению нового способа конфигурирования правил маршрутизации — теперь уже на основе заданных AF (т.е. для каждого AF создавалась отдельная карта маршрутов). Но на основе AF можно создавать не только карты маршрутов, но и осуществлять разного рода фильтрацию, т.е. создавать списки префиксов, списки преобразования, списки разрешения доступа на основе атрибута AS_PATH и т.д. Теперь, с введением нового стиля конфигурирования правил маршрутизации, уже не требуется ключевое слово nlri, и при анализе карты маршрутов выражения match nlri игнорируются.

Согласно AF-стилю, правила маршрутизации теперь можно описать следующим образом:

router  bgp 109

neighbor 1.1.1.1

remote-as

1

neighbor 1.1.1.1

!

route-map

filter-ucast

in

address-family  ipv4   multicast neighbor  1.1.1.1  activate

neighbor  1.1.1.1  route-map  filter-mcast   in

!

route-map filter-mcast permit 10

match ip address 1

!

route-map filter-mcast permit 10

match ip address 2

Преобразование

Преобразование — это процесс импортирования маршрутов из одного протокола маршрутизации в другой. Когда маршруты преобразуются в BGP-маршруты посредством команды redistribute, следует создать таблицу BGP-маршрутов (Adj-RIB-In), в которую и будут импортироваться маршруты. Эта таблица BGP-маршрутов может содержать как уникальные адреса, так и групповые.

Старый стиль

Старый стиль задания таблицы, в которую должны были помещаться маршруты, предполагал применение выражения set nlri в карте маршрутов. При выполнении преобразования это выражение в карте маршрутов использовалось следующим образом:

·          set    nlri  multicast–    преобразование  соответствующих  префиксов  в  групповую таблицу;

·          set nlri unicast multicast — преобразование соответствующих префиксов в таблицу с уникальными адресами и в таблицу с групповыми адресами;

·          set nlri unicast — преобразование соответствующих префиксов только в таблицу с уникальными адресами;

·          set   nlri–   преобразование   с   неявным   указанием   (в   этом   случае   выполнялось преобразование в таблицу с уникальными адресами).

Ниже на примере показано преобразование в BGP. Здесь, как видите,  все "связанные" префиксы, соответствующие списку разрешения доступа I в таблице маршрутов, импортируются как групповой NLRI:

router bgp 109

redistribute connected route-map mbgp-source-map

!

route-map mbgp-source-map match ip address 1

set nlri multicast

Стиль AF

Команда redistribute, заданная в режиме AF, определяла таблицу, в которую помещались префиксы после преобразования. Например, если выражение redistribute задавалось в режиме address-family ipv4 multicast, то преобразованные префиксы помешались в таблицу как групповые NLRI IPv4. Следовательно, предыдущая конфигурация преобразования, согласно старому стилю, трансформировалась в следующую:

router 109

address-family ipv4 multicast

redistribute connected route-map mbgp-source-map

!

route-map mbgp-source-map match ip address 1

Отметим, что с вводом выражения redistribute в режиме AF, отпадает необходимость в использовании ключевой цепочки set nlri и далее при анализе карты маршрутов последняя будет игнорироваться.

Отражатель маршрутов

Теперь конфигурация отражателя маршрутов также может выполняться на основе семейства адресов, что позволяет делать это более гибко и с меньшими затратами по сравнению со старым "централизованным" методом. В этом разделе мы обсуждаем и старый, и новый стили конфигурации отражателя маршрутов.

Старый стиль

Согласно старому стилю свойства  клиентов отражателя  маршрутов описывались глобально, и вся конфигурация затем применялась ко всем AF, поддерживаемым его клиентами. Отражатель маршрутов "знал", что отражение маршрутов от и к клиентам должно осуществляться по команде route-reflector-client, где указывался определенный узел или группа узлов IBGP. Далее приведен пример, где узел IBGP с адресом 1.1.1.1 становится клиентом отражателя маршрутов и для уникальных, и для групповых префиксов IPv4:

router bgp  109

neighbor  1.1.1.1   remote-as   109 nlri unicast multicast neighbor  1.1.1.1  route-reflector-client

Стиль AF

Может ли узел или группа узлов быть клиентами отражателя маршрутов, зависит, согласно стилю AF, от семейства адресов. В таком случае конфигурация их как клиентов проводится в режиме AF. Другими словами, то, что узел является клиентом отражателя маршрутов, поддерживающего уникальную адресацию по IPv4, совершенно не означает, что этот узел является одновременно и клиентом отражателя маршрутов для групповых адресов IPv4. Теперь это необходимо указывать явно при конфигурации клиента в режиме AF как поддерживающего работу с групповыми адресами IPv4. Таким образом, предыдущая конфигурация, когда узел 1.1.1.1 становился клиентом для работы по уникальным и групповым адресам, теперь будет иметь такой вид:

router bgp

109

neighbor

1.1.1.1

remote-as

109

neighbor   1.1.1.1   route-reflector-client

!

address-family ipv4 multicast

neighbor   1.1.1.1   activate

neighbor   1.1.1.1 route-reflector-client

Новый режим дает оператору определенную гибкость при конфигурации маршрутизатора в качестве отражателя маршрутов только для определенных AF. Таким образом, топология отражателей маршрутов для различных AF может варьироваться.

Объединение

Конфигурация объединения одного или нескольких AF была всегда довольно сложной задачей, особенно, если возникала необходимость в обеспечении определенных правил маршрутизации. В этом разделе мы приводим некоторые сведения о старых и новых методах конфигурации объединения маршрутов.

Старый стиль

В старом стиле объединение маршрутов с групповыми адресами конфигурировалось точно так же, как и объединение маршрутов с уникальными адресами — с помощью команды aggregate-address. Команда aggregate-address затем была дополнена, что позволило с помощью ключевого слова nlri указывать, к каким адресам (уникальным или групповым) она относится. Ниже приведен пример генерации объединенного маршрута в таблице групповых BGP-адресов:

router bg   109

aggregate-address   174.0.0.0   255.0.0.0   as-set nlri multicast

Параметры nlri, которые можно было использовать в команде aggregate-address, – unicast, multicast и unicast multicast. С их помощью в таблице BGP-маршр/тов генерировались объединенные маршруты с уникальными, групповыми или теми и другими адресами. В отсутствие ключевого слова nlri объединенные маршруты генерировались только с уникальными адресами.

Стиль AF

С появлением режимов AF для каждого семейства адресов исчезла необходимость использования ключевого слова nlri в команде aggregate-address. Режим AF, в котором теперь указывался объединенный маршрут, определял в какую таблицу будет помещаться сгенерированный объединенный префикс. Таким образом, в стиле AF объединенный маршрут описывался следующим образом:

router bgp 109

!

address-family ipv4 multicast

aggregate-address 174.0.0.0 255.0.0.0 as-set

Список команд BGP

В табл. Г-1 приводится список команд протокола BGP и категория, к которым они относятся.

Таблица Г-1. Команды и субкоманды BGP, сгруппированные по категориям

Команда/Субкоманда

Категория

address-family ipv4 unicast

Может один раз применяться в режиме router bgp

address-family ipv4 multicast

Может один раз применяться в режиме router bgp

aggregate-address

Согласно AF

auto-summary

Согласно AF

bgp ahvays-compare-med

Глобальная для BGP

bestpath

Глобальная для BGP

clicnt-io-cliem

Согласно AF

cluster-id

Глобальная для BGP

confederation

Глобальная для BGP

dampening

Согласно AF

default

Глобальная для BGP

determministic-med

Глобальная для BGP

fast-external-fallover

Глобальная для BGP

log-neighbor-changes

Глобальная для BGP

redistribute-internal

Глобальная для BGP

router-id

Глобальная для BGP

scan-time

Согласно AF

default- metric

Глобальная для BGP

distance

Согласно AF

maximum-paths

Согласно AF

neighbor

Применяется по согласованию между соседними узлами

activate

Согласно AF

advertisement-interval

Глобальная для соседнего узла (на время сеанса)

default-originate

Согласно AF (правила маршрутизации)

description

Глобальная для соседнего узла

distribute-Iist

Согласно AF (правила маршрутизации)

ebgp-multihop

Глобальная для соседнего узла (на время сеанса)

filter-list

Согласно AF (правила маршрутизации)

local-as

Глобальная для соседнего узла (на время сеанса)

maximum-prefix

Согласно AF (правила маршрутизации)

next-hop-self

Глобальная для соседнего узла (на время сеанса)

password

Глобальная для соседнего узла (на время сеанса)

peer-group

Согласно AF (правила маршрутизации)

prefix-list

Согласно AF (правила маршрутизации)

remote-as

Глобальная для соседнего узла (на время сеанса)

remove- private- AS

Глобальная для соседнего узла (на время сеанса)

route-map

Согласно AF (правила маршрутизации)

route-reflector-clicnt

Согласно AF

send- community

Согласно AF (правила маршрутизации)

shutdown

Глобальная для соседнего узла (на время сеанса)

soft-reconfi?unilion

Согласно AF Справила маршрутизации)

Команда/Субкоманда

Категория

timers

Глобальная для соседнего узла (на время сеанса)

update-source

Глобальная для соседнего узла (на время сеанса)

version

Глобальная для соседнего узла (на время сеанса)

weight

Согласно AF (правила маршрутизации)

network

Согласно AF

redistribute

Согласно AF

syncronization

Согласно AF

table-map

Согласно AF

timers

Глобальная для BGP

Переход к использованию стиля AF

Для того чтобы совершить плавный переход от одного стиля к другому, в новой версии была сохранена поддержка некоторых команд версии 12.OS  (которые позволяют использовать ключевое слово nlri). Вот эти команды:

•                               neighbor

•                               network

•                               aggregate

•                               set nlri и match nlri в картах маршрутов

Единственное предостережение: команды старого стиля могут использоваться до те.х пор, пока не требуется активизировать новые функции. В этом случае команды BGP старого стиля следует транслировать в команды нового стиля.

Чтобы перейти к использованию нового набора команд, в режиме конфигурации

маршрутизатора нужно ввести команду bgp up grade-cli:

Router(config-router)#bgp upgrade-cli

Старая конфигурация будет преобразована в новую. Далее, как обычно, нужно выполнить wr mem, чтобы сохранить новую конфигурацию. (Замечание: сама команда bgp upgrade-cli в конфигурации не отображается).

Источник: Сэм Хелеби, Денни Мак-Ферсон, Принципы маршрутизации в Internet, 2-е  издание.  : Пер. с англ. М. : Издательский дом «Вильямс», 2001. — 448 с. : ил. — Парал. тит. англ.

Вы можете следить за любыми ответами на эту запись через RSS 2.0 ленту. Вы можете оставить ответ, или trackback с вашего собственного сайта.

Оставьте отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 
Rambler's Top100